[Guide] RoR Under Linux

Problems installing or downloading the game? Check the Technical Support Sticky first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE STICKIED THREADS BEFORE YOU POST IN THIS SUBFORUM.

READ THEM THOROUGHLY.


The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
gemgem
Posts: 5

Re: [Guide] RoR Under Linux

Post#141 » Tue Apr 30, 2019 9:00 pm

wine-tkg-staging-esync-marchopt-git-4.7
d9vk verison spam errors
warn: Direct3DDevice9Ex::SetMaterial: Stub
cant see name and hp bar
cant see all spell effects
Image

Ads
User avatar
xpander
Posts: 25
Contact:

Re: [Guide] RoR Under Linux

Post#142 » Thu May 02, 2019 10:30 pm

Nice. Got it working also

wine-tkg-staging-esync 4.7
d9vk 2a217a40
winetricks dotnet40 d3dx9

Image

had to disable the error log spam, for more consistent frametimes with:
export DXVK_LOG_LEVEL=none

Seems fine so far, but i haven't done any extensive testing yet, ran around for like 30 min. Ground textures seem fine with D9VK and arent overly bright like with wined3d.

User avatar
zachary
Posts: 10

Re: [Guide] RoR Under Linux

Post#143 » Fri May 03, 2019 11:55 am

I was consistently getting disconnected when 3+ warbands came into view, until I started killing my audio driver (in another window: `pulseaudio -k`). Anyone else have this problem? Is there a better solution? This one is a bit painful as it either means acrobatics to get mumble/discord working again after, or moving mumble/discord to my phone.

User avatar
xpander
Posts: 25
Contact:

Re: [Guide] RoR Under Linux

Post#144 » Fri May 03, 2019 12:33 pm

zachary wrote:
Fri May 03, 2019 11:55 am
I was consistently getting disconnected when 3+ warbands came into view, until I started killing my audio driver (in another window: `pulseaudio -k`). Anyone else have this problem? Is there a better solution? This one is a bit painful as it either means acrobatics to get mumble/discord working again after, or moving mumble/discord to my phone.
i don't think i have seen that many people yet, but im only in tier 1 also. so just about 2 warbands max in my playing and no issues with sound cutting out. i do use JACK + pulseaudio however. If your sound cuts out it might be that pulseaudio can't keep up, so you might want to check the pulseaudio configuration to modify the fragment sizes etc, or it might be something wine related. Do you have wine built with faudio? would be good to check dmesg, journalctl logs or wine logs when that happens, to see whats really going on

nortes
Posts: 16

Re: [Guide] RoR Under Linux

Post#145 » Fri May 03, 2019 6:30 pm

Dephyant wrote:
Sat Mar 23, 2019 10:36 pm
Recently an update in arch killed font rendering in the launcher and the game so I went with a clean wine install to clear it up. I added wine-nine on top of wine-4.3 (Staging)
which greatly improved performance. I did that standard setup dotnet40, d3dx9(at first also did d3dx9_36?). I enabled galilum and disabled CSMT as CSMT seems no longer needed with this setup. I've encountered some graphical glitches with particle effects which you can kinda see in this SS down in the fog.

Anytime there is a spell effect on me it's like I'm in a black bubble if the camera is panned down close to my character. I was wondering if anyone else has seen this?

I've tried enable/disable glsl, csmt etc. Various in game setting but nothing has changed with those effects.
I use wine 4.5-staging atm, and I noticed such a thing - if you disable CSMT, the textures of the characters and the environment periodically begin to look the same as you described, so i think its better to turn this option on and maybe try wine 4.5?

ggnoredo
Posts: 1

Re: [Guide] RoR Under Linux

Post#146 » Sun Jun 02, 2019 2:05 pm

Hi,

I can't run this on my system. I have wine 4.9 with dotnet and directx but whenever i try to run RoRLauncher.exe it exists with failed, status c0000135 error code

gemgem
Posts: 5

Re: [Guide] RoR Under Linux

Post#147 » Mon Jul 01, 2019 7:33 am

d9vk
Latest version solved
fixed cant see any floating icon / hp_bar / all_name
fixed cant see any spell effects
but a bit strange than the original special effects
Image

Image
csmt effects
Image
d9vk effects

Latest version bug
hud show graphics pipelines : 70000+ keep going up few minutes until crash
crash bug was fixed with this version 346883d

sover
Posts: 1

Re: [Guide] RoR Under Linux

Post#148 » Mon Jul 08, 2019 8:33 pm

After many attempts and reinstalling dotnet40 I managed to get the Launcher up and running. I can click all the buttons and update the game without problems. But...

ISSUE: If I interact with (click or tab to) the area where I am supposed to put my Username and Password the Launcher immediately crashes.
During the crash the PlayOnLinux Debugger shows:

Code: Select all

0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D77C 0033DDE0 00000000
0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D96C 0033DFD0 00000000
0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D96C 0033DFD0 00000000
0009:fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime"): stub
0009:fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000401,(nil),0x0001,0x00000000,0x33db1c,(nil)): stub
0009:err:eventlog:ReportEventW L"Application: RoRLauncher.exe\nFramework Version: v4.0.30319\nDescription: The application requested process termination through System.Environment.FailFast(string mess0009:fixme:advapi:DeregisterEventSource (0xcafe4242) stub
I installed the game through PlayOnLinux using wine 4.12.1 and the components dotnet40, msxml3 and d3dx9.
It seems like .NET 4.0 is a mess and difficult to get working under wine.

Ads
User avatar
ufthakk
Posts: 29

Re: [Guide] RoR Under Linux

Post#149 » Wed Jul 10, 2019 10:40 am

@sover maybe try to change compatibility to winxp to install dotnet and after that back to win7.
Also setting up a virtual screen in pol winecfg might help.

Pampi
Posts: 1

Re: [Guide] RoR Under Linux

Post#150 » Tue Aug 20, 2019 6:01 pm

@sover
I managed to avoid a crash when I put my cursor in a text field by installing windows fonts to my wine prefix.
Spoiler:

Code: Select all

0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D77C 0033DDE0 00000000
0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D96C 0033DFD0 00000000
0009:fixme:combase:RoGetParameterizedTypeInstanceIID stub: 2 075D7A70 0033D96C 0033DFD0 00000000
0009:fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime"): stub
0009:fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x00000401,(nil),0x0001,0x00000000,0x33db1c,(nil)): stub
0009:err:eventlog:ReportEventW L"Application: RoRLauncher.exe\nFramework Version: v4.0.30319\nDescription: The application requested process termination through System.Environment.FailFast(string mess0009:fixme:advapi:DeregisterEventSource (0xcafe4242) stub

Code: Select all

winetricks corefonts
Enjoy !

Who is online

Users browsing this forum: Bing [Bot] and 7 guests