Ground textures appear very pixelated when moving

Ask for in-game support. Bugs go to the Bug Tracker.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE STICKIED THREADS BEFORE YOU POST IN THIS SUBFORUM.

READ THEM THOROUGHLY.


The RoR staff do not apologize for flippant or otherwise objectionable responses made to posters who refused to read the stickies before they made a post. Save our time and yours by reading the stickies first.

Thank you.
Zewks
Posts: 4

Ground textures appear very pixelated when moving

Post#1 » Sun May 12, 2019 6:53 am

Not sure whats causing this. None of the other textures in the game have this issue. Just ground textures. Standing still looks fine.

However, as soon as I start to move forward or backward, there will be noticeable sections of the ground textures that no longer appear smooth, but seem to appear much more pixelated. Like they have been over sharpened or something.

I thought it might have something to do with AF (anisotropic filtering) since the game has none built in, but I tried to force it in the default nvidia drivers, to 16x, and it seemed to have no effect on this. I dont know, maybe forcing it through the control panel wasnt actually enabling it??

Here is a quick vid I took, make sure to watch it in 1080, otherwise the lower quality video may mask the effect.

https://www.youtube.com/watch?v=Vz-Czo7-WOc

If this IS indeed fixed by AF, can anyone tell me what im doing wrong to try and enable it?

Ads
User avatar
saupreusse
Posts: 1809

Re: Ground textures appear very pixelated when moving

Post#2 » Sun May 12, 2019 7:29 am

Yes AF but mostly your resolution. If your gpu can handle it try to crank it up to 1440p or even 2160p. Im runnin 2160p and AF to get rid of the flimmering.

Zewks
Posts: 4

Re: Ground textures appear very pixelated when moving

Post#3 » Sun May 12, 2019 7:41 am

I bumped the res up to 4k. Probblem is still nearly as noticeable.

No idea why AF isnt working when im forcing it via nvidias control panel

After I posted my original post, I went and grabbed Nvidia Inspector, and loaded up the WaR profile (making sure to that the 64exe as well). Using that tool I force AFx16. It STILL seems to do absolutely nothing to fix this issue.

Its like the game just completely ignores AF, or im completely missing something.

User avatar
Phantasm
Posts: 26

Re: Ground textures appear very pixelated when moving

Post#4 » Sun May 12, 2019 6:05 pm

Maybe I`m bling but I dont see anything:)
Edit, on second watch, did u mean that ground in distance at the end of road? Same effect when u got stairs and u looks in angle?
In that case I got same flickering on AMD rx 580.

User avatar
saupreusse
Posts: 1809

Re: Ground textures appear very pixelated when moving

Post#5 » Sun May 12, 2019 6:38 pm

Zewks wrote:
Sun May 12, 2019 7:41 am
I bumped the res up to 4k. Probblem is still nearly as noticeable.

No idea why AF isnt working when im forcing it via nvidias control panel

After I posted my original post, I went and grabbed Nvidia Inspector, and loaded up the WaR profile (making sure to that the 64exe as well). Using that tool I force AFx16. It STILL seems to do absolutely nothing to fix this issue.

Its like the game just completely ignores AF, or im completely missing something.
interesting. this worked fine for me. it could be that the AF isnt applied. try using the 32bit exe and make sure you run the game from your C drive. Maybe it will apply then :S

Zewks
Posts: 4

Re: Ground textures appear very pixelated when moving

Post#6 » Mon May 13, 2019 1:44 am

saupreusse wrote:
Sun May 12, 2019 6:38 pm
Zewks wrote:
Sun May 12, 2019 7:41 am
I bumped the res up to 4k. Probblem is still nearly as noticeable.

No idea why AF isnt working when im forcing it via nvidias control panel

After I posted my original post, I went and grabbed Nvidia Inspector, and loaded up the WaR profile (making sure to that the 64exe as well). Using that tool I force AFx16. It STILL seems to do absolutely nothing to fix this issue.

Its like the game just completely ignores AF, or im completely missing something.
interesting. this worked fine for me. it could be that the AF isnt applied. try using the 32bit exe and make sure you run the game from your C drive. Maybe it will apply then :S
So I tried the 32bit version, and from C

Here is the odd thing... i was also trying to cap the framerate at 60, since i dont like screentearing, and that ALSO wasnt working with nvidia inspector or the nvidia control panel.

Using the 32bit exe, now the framerate cap works using inspector... but the AF still doesnt seem to work at all.

Makes zero sense

Zewks
Posts: 4

Re: Ground textures appear very pixelated when moving

Post#7 » Mon May 13, 2019 2:08 am

Here is another sample video

https://www.youtube.com/watch?v=JNmmCk9-DcM

Make sure to bump it to HD, and close to full screen. Watch the textures on the dirt path

They shouldnt be getting that shimmery with pixels.

And AF is forced on using Nvidia inspector for both the warhammer and general profiles.

User avatar
Grolar
Posts: 507

Re: Ground textures appear very pixelated when moving

Post#8 » Mon May 13, 2019 3:56 am

Most likely your resolution is low or your anti-aliasing or mip-mapping settings are whack on your video card. Looks fine on mine. Also... This is an 11 year old game. Pixels happen.
THUMP - "MEDIOCRE!!" ...Who's laughing now?

Image

Ads
User avatar
Wdova
Posts: 366

Re: Ground textures appear very pixelated when moving

Post#9 » Mon May 13, 2019 7:17 am

Dont worry about this. In fight of warband vs warband or zerg blob vs zerg blob you not gonna have time to study pixelated ground textures :)
Active
SM - Hajzl 40/7X
Slayer - Lokomotiv 40/7X
BW - Pyromanka 40/6X

Inactive
Kotbs - Valdstein 40/5X
WH - Vevoda 40/5X

User avatar
saupreusse
Posts: 1809

Re: Ground textures appear very pixelated when moving

Post#10 » Mon May 13, 2019 7:48 am

Zewks wrote:
Mon May 13, 2019 2:08 am
Here is another sample video

https://www.youtube.com/watch?v=JNmmCk9-DcM

Make sure to bump it to HD, and close to full screen. Watch the textures on the dirt path

They shouldnt be getting that shimmery with pixels.


I had this problem on my old computer. Nvidia inspector would only work for framerate capping and not af or aa. In 2 years i was unable to fix it :( on my new rig its working fine again. Maybe you
Could try using reshade. Theres a forum post from sildur how to set it up.

Who is online

Users browsing this forum: No registered users and 3 guests