Help installing the game - March 2020 Update

Problems installing or downloading the game? Check the Install Guide first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE INSTALL GUIDE BEFORE YOU POST IN THIS SUBFORUM.

The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
User avatar
Lilim
Advisor
Posts: 631

Re: Help installing the game - March 2020 Update

Post#261 » Wed Dec 02, 2020 11:53 am

mortbolt wrote:
Wed Dec 02, 2020 11:07 am
I need help, every time I launch the launcher I get this error

"Disconnected from server. Error: System.Net.Sockets.SocketException (0x80004005): A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
at RoRLauncher.Client.q4n090Jg8IbBPg6aMFq(Object , Object )
at RoRLauncher.Client.Hnw1heD1Cx(Object ) "

What can I do to fix it?
Hey,

the login server is currently down...so maybe this cause the issue...for other stuff...here the install guide:

How to Download:
+ Recommend Torrent Tixati: http://www.tixati.com/
+ First step, disable your Antivirus, Firewall, or Malware detection programs. These can potentially interfere with an install.
+ Download torrent file: https://www.returnofreckoning.com/files ... 20.torrent
+ Run the Torrent file, with the Torrent app, and wait until it's finishes.

How to Install:
+ Stop your Torrent from seeding (close it, maybe check your task manager)
+ Move the Warhammer Online - Return of Reckoning outside the ReturnofReckoning-March2020 folder and move it to c:\ ... for instance move it to c:\Games
(but NOT inside c:\ Program Files or c:\ Program Files (x86); it should be in a folder which it have write access)
+ Remove the write-protection from all the files in the Warhammer Online - Return of Reckoning folder.
(right click on the War Online - RoR folder > properties > disable the read-only box)
+ Check that your whole Warhammer Online - Return of Reckoning folder is whitelisted in your Antivirus program and check if your Firewall or Maleware doesn't interfere with the install.
+ You may also try running the launcher with Administrator privileges.
(Right click on the RoRLauncher.exe > properties > run administrator)
+ Run the RoRLauncher.exe
+ Let it update (sometimes it needs a few seconds until it starts)
+ Exit launcher and rerun it again
+ Repeat the last 2-steps until there is no update left
+ Launch the game

!!! [If you don't have DirectX 9.0c, installed it is required, and now this is also included in the torrent. In the ReturnOfReckoning-March2020 folder find the dx90c folder, open that and run DXSETUP.exe]

Ads
ultimateduck
Posts: 1

Re: Help installing the game - March 2020 Update

Post#262 » Mon Dec 21, 2020 1:59 am

A few things I don't get, when I initially tried to install the game, I flat out got a trojan virus warning. This, of course, worried me because it wasn't just a suspicious site or unknown publisher thing, it was a flat out trojan virus thing. But, I figure I haven't formatted my drives in a while so why not... YOLO.

I've tried everything with zero luck. I turned everything possible off and I couldn't get this game to download and run.

Ironxwielder
Posts: 1

Re: Help installing the game - March 2020 Update

Post#263 » Wed Feb 10, 2021 4:17 am

can anyone help im still running into the war-64 error. thanks in advance

Fenrirnoatun
Posts: 2

Re: Help installing the game - March 2020 Update

Post#264 » Wed Feb 10, 2021 10:50 am

i am still getting the war-64 error after downloading the extra 2 files from the other thread , ive done everything, redownloaded ,opening everything as admin even installt dx9 on its own a second time + the warhammer files wont let me change them from read only to edit..

*EDIT* i think i put it in program files(x68) , trying to download it again and put it just in D:

User avatar
Nethar89
Posts: 2

Re: Help installing the game - March 2020 Update

Post#265 » Tue Feb 23, 2021 7:47 am

Hey everybody!

It sad as my first post to this community must be a request of help, but after seeing you Q&A session on youtube, I am so excited to play!
But after 3 days of waiting and failed attempts, I still could not make it work. Here is the issue:

THE PROBLEM:
The game seems fully downloaded, I can see the intro cinematics and reach the server interface. I am prompted to create a character, but there is no 3D models nor texture. Everything is black. I blindly managed to click through it and created a character nonetheless. I tried to enter the world with this character, but after the loading screen everything crashes with no error. This happens regardless of the strategy used to install the software.
Note: folder is whitelisted, DirectX installed, Windows 10, final install folder has 11,1Gb of files)

MY ATTEMPTS:
Torrent:
It has been 3 days already, but it still haven't finished the download. It would be lovely if somebody could put it on seed again. I am missing about 10Mb since 2day, but those are fragmented pieced between 4 large files: art3/data/interface/video.myp
(I use the torrent link on your Download page: https://www.returnofreckoning.com/join.php#download)

What did I try already:
1. I tried to transfer the Torrent files into another folder and removed the fragmented files mentioned above. Then run the launcher to recover the missing files. It took it hours to download the missing 2Gb, but all seemed fine. Run the launcher a few more time but there are no more files to recover. Try to run but I have the no texture issue described above.
2. Found an alternative source of files kindly posted by desizt a few post before this one. Again, I have downloaded all the files, run the launcher, recovered the (very few) missing ones and start the game. Again: no 3d models visible and no texture, the game crashes if I try to enter the world with any character.

I am not sure of which kind of problem I am struggling with. It seems different from all that is already mentioned in this thread, of people struggling to get their files updated. I have the launcher do everything smoothly, but then the game has no texture.
Sure I may have some corrupted file somewhere, but I do no think it is the case because I have installed it from 2 independent sources and the file from desizt was a single zip, with no damage. I hope it will work once I will run the whole process once again starting from the torrent file (if it will ever finish to download!). But I actually wonder if they problem may be something else I am overlooking at.

Thanks for any feedback/help! :D

User avatar
Lilim
Advisor
Posts: 631

Re: Help installing the game - March 2020 Update

Post#266 » Tue Feb 23, 2021 11:18 am

Spoiler:
Nethar89 wrote:
Tue Feb 23, 2021 7:47 am
Hey everybody!

It sad as my first post to this community must be a request of help, but after seeing you Q&A session on youtube, I am so excited to play!
But after 3 days of waiting and failed attempts, I still could not make it work. Here is the issue:

THE PROBLEM:
The game seems fully downloaded, I can see the intro cinematics and reach the server interface. I am prompted to create a character, but there is no 3D models nor texture. Everything is black. I blindly managed to click through it and created a character nonetheless. I tried to enter the world with this character, but after the loading screen everything crashes with no error. This happens regardless of the strategy used to install the software.
Note: folder is whitelisted, DirectX installed, Windows 10, final install folder has 11,1Gb of files)

MY ATTEMPTS:
Torrent:
It has been 3 days already, but it still haven't finished the download. It would be lovely if somebody could put it on seed again. I am missing about 10Mb since 2day, but those are fragmented pieced between 4 large files: art3/data/interface/video.myp
(I use the torrent link on your Download page: https://www.returnofreckoning.com/join.php#download)

What did I try already:
1. I tried to transfer the Torrent files into another folder and removed the fragmented files mentioned above. Then run the launcher to recover the missing files. It took it hours to download the missing 2Gb, but all seemed fine. Run the launcher a few more time but there are no more files to recover. Try to run but I have the no texture issue described above.
2. Found an alternative source of files kindly posted by desizt a few post before this one. Again, I have downloaded all the files, run the launcher, recovered the (very few) missing ones and start the game. Again: no 3d models visible and no texture, the game crashes if I try to enter the world with any character.

I am not sure of which kind of problem I am struggling with. It seems different from all that is already mentioned in this thread, of people struggling to get their files updated. I have the launcher do everything smoothly, but then the game has no texture.
Sure I may have some corrupted file somewhere, but I do no think it is the case because I have installed it from 2 independent sources and the file from desizt was a single zip, with no damage. I hope it will work once I will run the whole process once again starting from the torrent file (if it will ever finish to download!). But I actually wonder if they problem may be something else I am overlooking at.

Thanks for any feedback/help! :D
Hey,

you can download the game (it's an almost up-to-date version) via this google drive link: https://drive.google.com/file/d/1zra6wB ... sp=sharing

If you can't see 3D models:
- close your game and launcher
- reopen the launcher and wait if there are patches left
- if not, press the cog and use the repair function

User avatar
Nethar89
Posts: 2

Re: Help installing the game - March 2020 Update

Post#267 » Tue Feb 23, 2021 10:20 pm

Thanks Lilim for your prompt answer. :D

Unfortunately, none of the following have worked:
* Reinstall DirectX
* Make repair of previous installation
* reinstall from scratches using your Drive link
* reinstall from scratches using the Torrent files (finally the download had finished, thanks to whoever started seeding again!)
* try to run on 32/64-bits
* make sure folder is whitelisted on my Antivirus

Endpoint is always the same: a partial interface with a black background and no 3D models. If I blindly navigate until I make a character and enter the world, the game crashes with no messages.

Screenshots:
https://drive.google.com/file/d/122w0nb ... sp=sharing
https://drive.google.com/file/d/1Hu4ryz ... sp=sharing

Since all the files brings to the same output, I have to assume my problem lays somewhere else. If you have any other idea, please let me know.

Who is online

Users browsing this forum: Google Adsense [Bot] and 18 guests