Recent Topics


Cannot create character

Problems installing or downloading the game? Check the Install Guide first.

Moderators: Developer, Management, Web Developer

Forum rules

The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
Posts: 1

Cannot create character

Post#1 » Fri Jul 03, 2020 7:25 pm

Like the title says, cannot create character. When I move the cursor over each race the text at the top of the screen changes showing the description of that race. I cannot select a race. The server button doesn't work either.

Posts: 2

Re: Cannot create character

Post#2 » Sun Jul 12, 2020 5:11 pm

Hello, I have the exact same problem. I already tried clearing out the cache folder but it didnt work. Newest mouse drivers are installed.
I reinstalled the game but the problem is still there. I installed the game as suggested by the instructions.
The folder is Whitelisted and I launch the game as admin with the RoRlauncher.exe. The game starts normal until i'm in the faction choosing screen. I can move the mousecursor around but i can't click anything.
If anyone has a solution to the problem I'm having, help would be deeply appreciated as i am super excited to start playing the game.
Thanks in advance :)

Edit: I fixed the issue by using the repair option in the launcher, then closing the launcher, uncheck the read only box in the foldermenu of the game folder again. also i set the launcher to 32bit. restarted the game and it worked

Who is online

Users browsing this forum: Casca42 and 16 guests