Page 1 of 1

Scenario Left Click

Posted: Sat Nov 21, 2020 2:34 pm
by Hibl
Hi, i have a "problem" in Scenarios.

After i join i cant use my rightclick. i have to /rel. when i die in scenario its the same. i have to /rel. Also i cant leave the scenario when its finished. I have to wait the 2 Minutes to get kicked. i also can not see numbers on the scoreboard, its all white. After i played one scenario i have to /rel in every new zone.

I searched in the forum and reddit and it seems a few other guys have this problem too. But noone had a solution except the /rel thing.I tried a few things like delete cache and all addons. Nothing helps.

I mean its playable with /rel but if you have a better solution that would be really nice. thanks in advance.

Re: Scenario Left Click

Posted: Sun Nov 22, 2020 7:38 am
by xpander
since your scoreboard is also white, i would think that either your game hasnt patched fully or you have some permission issues with the RoR files/folder .

Now without the white scoreboard i would say maybe some sort of overlay tools might break the mouse buttons: like fps counters or similar

Re: Scenario Left Click

Posted: Sun Nov 22, 2020 2:14 pm
by Hibl
thx for your answer. i allready reinstalled the game and removed all addons. doenst work

Re: Scenario Left Click

Posted: Sun Nov 22, 2020 3:07 pm
by xpander
check the read-only thing. im quite sure you have some sort of permission issue somewhere

Things to try:
- Remove the write-protection from all the files in the WAR folder. (right click the game folder -> properties -> disable the read-only box)
- Check if your whole RoR Folder is whitelisted in your Antivirus program and check if your Firewall or Maleware doesn't interfere with the install.
- You may also try running the launcher with Administrator privileges. (Right click the RoR updater > properties > run administrator)
- Run the RoRLauncher.exe
- Let it update (sometimes it needs a few seconds until it starts)
- Exit launcher and rerun it again
- Repeat the last 2-steps until there is no update
- Launch the game

Re: Scenario Left Click

Posted: Sat Nov 28, 2020 10:45 am
by Love
Don t work for me.I can t queue scenario,i don t see minimap in top right corner,i can t click with right mouse on names in chat.
When i join in game i don t have a loading screen.I have a black screen and a white text "Loading Aldorf..."

Re: Scenario Left Click

Posted: Sat Nov 28, 2020 10:48 am
by billyk
Repair your launcher with the cog icon, then restart it. That's what fixed it for me.