Recent Topics


Key mapping

Ask for in-game support. Bugs go to the Bug Tracker.
Forum rules

The answers you may seek are likely already there.

Thank you.
Posts: 2

Key mapping

Post#1 » Sat Mar 02, 2024 2:44 pm

No issues for some time. But since a couple of months I have the following:
some keys assigned to hotbar stopped working.

So in the key mapping menu, when i try to assign theses keys it say "none".
List of keys than I can't assign: 2 7 9 0

I can use them in chat without issue.
I can use them on my PC without issue.
I cant bind them to any action.
Editting ProfileSettings.xml doesn't work

the 2 is especially annoying.

Using QMK:
assign the key value to other physical key give the same result.
assign another key value at theses emplacement allows me to bind them.
But them i need to revert back each time to use my keyboard anywhere else.

User avatar
Posts: 6

Re: Key mapping

Post#2 » Sun Mar 03, 2024 6:13 am

If you’re sure its not something related to your mouse software, then check the profile sharing feature in game, sometimes it messes up with the keybinds, so trying disabling it and create a totally new character to test keybinds again.

Posts: 2

Re: Key mapping

Post#3 » Sun Mar 03, 2024 2:46 pm

On old characters, the faulty keys are bind (the number appear on the hotbar) but not doing anything, no yellow border on key press. And when trying to bin them, same thing it give "none".
Same thing on new character.

i use piper to configure my mouse. Same result as with the keyboard. When I assign one of there input (2 7 9 0) on a mouse button its unusable, cant bind it ("none")

I just cant use theres keys values. not with shift, alt, ctrl, on any action, on any physical key of my keyboard nor on the mouse.
but i can write in chat with.
And, again, don't have this bug in any other game.

Posts: 93

Re: Key mapping

Post#4 » Mon Mar 04, 2024 10:34 am

There was(or still is apparently) some weird bug about some non-normal(so not m1-m5) mouse keys bound to, well anything stopping working because of... idk why it just did, happened on 2 different mice, mad catz mmo7 and a g502 on the non m1-m5 buttons. I can't remember at all if those buttons still worked on the keyboard though as skills.

The same bug also messed with the § key(left of 1 on a nordic keyboard) I'm assuming that has to do with it being a different key on uk/is keyboard than nordic and the ingame bind doesn't show the nordic input, rather the us/uk bind which is tilde i guess rather than §.
Not 100% sure, might've been some other game that had that big though.. it's been a while, but since it's my cleanse button i have some memory of it not working.

I never found out the reason why it happened sometimes, but for me just relaunching the game fixed it and I remember some talk about keeping the game in focus instead of alt tabbed while launching/loading stuff it helps or something, but i can't quickly recreate the bug now it seems.

So might be related might not.

One theory i had that it could also have something to do with keyboard layouts as i remember some valve games installed the US layout back even if you removed it and might accidentally switch to it(even if you removed the keybinding from windows to switch layouts btw, it still happened sometimes, was very annoying, no idea why, never found out) afterwards. So had to do some regediting to remove it more permanently from being ever added back, which worked, and the timing i did that kinda lines up with me remembering when the problems went away.

But that was ~3-4ish years ago so memory is a bit foggy and i don't really play much ror these days, nor do i use a mouse with extra buttons anymore as my main, still have it connected though. So can check if you're on the correct keyboard layout and don't have any extras.
Alteredheal 85 DOK
Azerrad 79 Sorc
Lumoojatar 70 AM

Who is online

Users browsing this forum: No registered users and 25 guests