Launcher Issue - possibly certificate related

Problems installing or downloading the game? Check the Technical Support Sticky first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE STICKIED THREADS BEFORE YOU POST IN THIS SUBFORUM.

READ THEM THOROUGHLY.


The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
User avatar
Skullgrin
Posts: 385

Launcher Issue - possibly certificate related

Post#1 » Wed Sep 19, 2018 1:52 am

Came home tonight and started RoRLauncher.exe in order to start the 18/09/2018 patching process, however the Web Server status is red and Login Server status is yellow, with the connect button greyed out. Came to the website where I noted that the server status widget isn't working, possibly due to the webserver being moved as noted here - viewtopic.php?f=2&t=28430&p=324023#p324023

Checking the server status via the "Who's Online" tool indicates that 220 people are currently in-game, so I decided to run RoRUpdater.exe thinking that my launcher had somehow been corrupted and needed to be replaced. This resulted in the following error -


Error Downloading updater:
System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
at System.Net.PooledStream.EndWrite(IAsyncResult asyncResult)
at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)


I'm not certain what all of it means, however I think it looks like the security certificate was rendered invalid due to the website being moved. I tried using the patcher Yaliskah privided a link to here - viewtopic.php?f=4&t=27103&hilit=Error+D ... &start=640
however it also has the same status problems (web=red, server=yellow). I have also tried connecting over a VPN, and restarting my computer just in case it was some other setting on my end that changed since logging in last night. No luck with either of those attempts.

I am out of ideas on what else to do on my end, any assistance would be greatly appreciated.
Image
Thargrimm - Chosen 40/85

User avatar
undeadbilly
Posts: 7

Re: Launcher Issue - possibly certificate related

Post#2 » Wed Sep 19, 2018 3:00 pm

Same here.Web=red,server=yellow since yesterday.

User avatar
Skullgrin
Posts: 385

Re: Launcher Issue - possibly certificate related

Post#3 » Thu Sep 20, 2018 2:42 am

Day two, still web=red, server=yellow. Tried the changing the system date trick that could be used if the security certificate had expired, no luck there. Please, could someone on the dev team respond to this, I've seen several posts on the forums now of others having the same issue since the server migration.

Ah well, off to see if I can get Hellgate: London running...
Image
Thargrimm - Chosen 40/85

User avatar
Ninjagon
Posts: 100

Re: Launcher Issue - possibly certificate related

Post#4 » Thu Sep 20, 2018 11:51 am

Web server green, login server red to me now.
Ninjagon, that Bright Wizard who excels in killing himself.
Spoiler:
Image

User avatar
Yaliskah
King of Nothing
Posts: 1674

Re: Launcher Issue - possibly certificate related

Post#5 » Thu Sep 20, 2018 11:54 am

Due to base transfer (probably), some things here and there are not working as intended.
Thx for you feedbacks.

DaScoub will take a look asap ( at work atm, transfer isn't finished. He will make an announcement when all done).

User avatar
Skullgrin
Posts: 385

Re: Launcher Issue - possibly certificate related

Post#6 » Fri Sep 21, 2018 3:27 pm

Day 3 - Had fun playing Hellgate London, however whenever I start the RoR launcher the status is still web=red, server=yellow.

Day 4 - According to this - viewtopic.php?f=2&t=28470 all the web migration is done, and I still can't connect to the game. Can someone please take a closer look at the error message I get and translate it please?

Guess I'll research some of the Hellgate graphical bugs and see if I can fix them...
Image
Thargrimm - Chosen 40/85

User avatar
undeadbilly
Posts: 7

Re: Launcher Issue - possibly certificate related

Post#7 » Fri Sep 21, 2018 5:07 pm

Same as Skullgrin here,and Kretschmer & Enrus in another topic.Web server is red,login server is yellow.Tried everything,run as admin,turn back clock,uncheck read only,patcher,change password,VPN.Even deleted game and download again from torrent,still same,since 18.09.

Enrus
Posts: 6

Re: Launcher Issue - possibly certificate related

Post#8 » Sat Sep 22, 2018 7:02 pm

My problem: in launcher server -red, login- yellow and dont update. I reinstaled game, use CCliner, antivirus and cmd commands from viewtopic.php?f=4&t=2889 But this not work.

User avatar
Skullgrin
Posts: 385

Re: Launcher Issue - possibly certificate related

Post#9 » Sun Sep 23, 2018 1:05 am

Day 5 - Tried to do the winsock repair that Enrus pointed out here - viewtopic.php?f=4&t=2889 - which I will copy/paste for others to try

Web Server appears red / Login Server appears yellow:

- This happens if the World server is down. There's a server status thread here.

- How to fix this problem (when it's not caused by the World server being down!):

1. click on start
2. type into the search-box cmd (before clicking enter press ctrl+shift) then also enter while holding them (runs cmd as admin)
3. the cmd window open up
4. type in:

netsh winsock reset catalog (resets winsock entries to install values)
netsh int ipv4 reset reset.log (resets ipv4 to install values)
netsh int ipv6 reset reset.log (reset ipv6 to install values)

5. restart the computer
6. log-in and enter the battlefield!

Unfortunately this DID NOT work for me, hopefully others may have some luck with it. Ah well, back to Hellgate London...
Image
Thargrimm - Chosen 40/85

User avatar
Wuu
Posts: 33

Re: Launcher Issue - possibly certificate related

Post#10 » Sun Sep 23, 2018 5:10 am

Try running as admin. I had the same issue as you and my shortcut was deleted by my antivirus. Relaunched program as admin and it's patching.
From zero. Guess it should be ready by the time I wake up.

Who is online

Users browsing this forum: vortigma and 3 guests