Recent Topics

Ads

Black Screen

Problems installing or downloading the game? Check the Install Guide first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE INSTALL GUIDE BEFORE YOU POST IN THIS SUBFORUM.

The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
skeletot
Posts: 5

Black Screen

Post#1 » Wed Dec 13, 2017 2:36 am

I went through the sticky and spent awhile browsing through topics to try and find a fix, but so far nothing has worked.
Connection seems fine, drivers are fine, nothing is read only, DX9 installed from installer listed in steps, etc. I'm not sure what is even causing the issue, I don't get prompted with any errors at all.

Image

Operating System: Windows 10 Pro 64-bit (10.0, Build 10586) (10586.th2_release.170904-1742)
Processor: AMD Athlon(tm) X4 880K Quad Core Processor (4 CPUs), ~4.2GHz
Memory: 16384MB RAM

Graphics: AMD Radeon (TM) R9 390 Series
Driver: 23.20.15002.11

Any help would be appreciated! Will provide more info if needed.

EDIT:

Tried a different dx9 dll in folder, didn't work.
Tried swapping from USB audio device, didn't work.
Ran it in various compatibility modes, didn't work.
Put WAR.exe into my graphics profiles and disabled various things like AMD shader optimization, didn't work.
Moved it to x86 program files as a shot in the dark, didn't work.
Reinstalled DX9 link from the instructions page, didn't work.
Deleted old install and downloaded the game again, didn't work.
Had friend install it on their laptop which is also win10 with the DX9 from the instructions page, worked for them, not for me.
Tried wineD3D as a shot in the dark, didn't work.
Clean installed drivers with DDU again and cleaned up some registry stuff, didn't work.
Reverted back to old drivers, didn't work.

EDIT:

Found a log file in the folder for a recent attempt, noticed that it has an error in it. No idea if this is related, or just something to do with the emulation.

\Warhammer Online - Age of Reckoning\logs
[2017/12/13 00:43:23] TCPNETSet::OSProcess EnumNetworkEvents call failed! Error code = 10038. Treating socket as closed.

Found something else in addition to the log file while looking for clues! There appears to be the remnants of another player's files within the folder. Is this common, or is someone seeding a bad installation? EDIT: Present in compressed version as well, compressed version also has the dx9 dll in it from the get go. This is likely just remnants of something, oops! Either way, prompted me to download the game again, still no luck.

EDIT:

Thought I'd explore the read-only side of things a bit more with the fresh folder from unpacking, found some administrator settings weren't on properly for my usual account. Took care of it, but still no result.
Last edited by skeletot on Tue Dec 19, 2017 8:30 am, edited 8 times in total.

Ads
User avatar
kmark101
Posts: 326

Re: Black Screen

Post#2 » Wed Dec 13, 2017 3:45 am

If you have 64bit Windows then make sure you install the 32bit Directx version as well (copy/paste it to the Warhammer folder), not only the 64bit version. It worked for me on 2 separate comps with the same issue.
Gryyw - Ironbreaker

skeletot
Posts: 5

Re: Black Screen

Post#3 » Wed Dec 13, 2017 5:23 am

kmark101 wrote:install the 32bit Directx version as well (copy/paste it to the Warhammer folder)
How would you go about getting the 32bit version to install? I looked around after seeing that a couple of places, but could never get it going. I tried one of the old faithful tricks of going into system32 and snagging d3dx9 dll file, then throwing it into the Warhammer folder, but that didn't work. I'm pretty sure there's something I'm missing.

User avatar
kmark101
Posts: 326

Re: Black Screen

Post#4 » Wed Dec 13, 2017 6:41 am

Download it from here: https://www.dll-files.com/d3dx9_34.dll.html

Then just copy/paste the dll file into your Warhammer folder.
Gryyw - Ironbreaker

skeletot
Posts: 5

Re: Black Screen

Post#5 » Wed Dec 13, 2017 6:59 am

Putting that DLL into the Warhammer folder didn't work, but thank you for the link! Still having the problem.

Auiga
Posts: 1

Re: Black Screen

Post#6 » Sat Dec 16, 2017 5:24 am

Hey there! Has there been any ideas for this one? I seem to be having the same problem. Could it be a problem with AMD?

skeletot
Posts: 5

Re: Black Screen

Post#7 » Tue Dec 19, 2017 8:41 am

Any ideas out there? Still having this issue and keep revisiting it on the side to see if I can figure it out. Everything else runs just fine on my PC, even other private servers like the Dark Age of Camelot one. Only thing I haven't tried is resetting windows, but I'd rather not do that yet.

User avatar
Stophy22
Posts: 336

Re: Black Screen

Post#8 » Fri Dec 22, 2017 8:34 pm

Could be tedious but try redownloading the torrent/client Whatever the problem is it in my experiences sometimes I just had to suck it up and re download the client and things worked fine doesn't always work but is worth a shot
Image
Kuro Mara R7x
Bunji DoK R6x
Kurodon BG R8x
Archea Chosen R6x

Ads
Axerker
Posts: 203

Re: Black Screen

Post#9 » Fri Dec 22, 2017 8:40 pm

Try turning your brightness up!

Sorry, that was a joke. On a serious note, are you launching/running as Administrator?

User avatar
Elven
Former Staff
Posts: 5141

Re: Black Screen

Post#10 » Fri Dec 22, 2017 8:46 pm

The error you posted looks like a network connection timeout between you and the server. Try deleting any user folders in your game client and see if that works.

If not, try replacing your launcher with this unpacked version: https://my.pcloud.com/publink/show?code ... FCn4UIAQ77

May also want to look into adding both Ror.exe and War.exe to exception lists for the firewall and antivirus, if you use any.

Who is online

Users browsing this forum: No registered users and 4 guests